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   حرف‌ اول 
سلام دوست من!

امیدوارم تو این مدتک ه نتونستم حالت رو بپرسم خوب بوده باشی.
حتما واست سوال هستک ه چرا بوم الان منتشر شده. حالا دلیلش رو واست میگم...
من و دوستانم تصمیم گرفتیم بوم 4 رو با محتوای غنی تر برای این دو ماه آمادهک نیم.

حالا لابد میپرسید اینک ار برای چیه!
دلم میخواست دلیل این تصمیم رو نگم! اماچهک نمک ه طاقت ندارم!

20 ام این ماه یک ویژه نامه فقط و فقط برای توییک ه تا این لحظه تنهامون نذاشتی، 
منتشر میشه. ذوقک ردی نه؟؟

اشتباه نکنیا! این ویژه نامه مستقل از بوم 5ه و بوم 5 رو میتونی در روز 1 شهریور 
دانلودک نی. این ویژه نامه یه هدیه ست... برای توک ه عاشق گرافیک هستی! 

مطمئنم خوشت میاد...
نشد دیییگه! تلاش بیهوده نکن... نمیتونی موضوعش رو از زیر زبونم 

بکشی! فکرک نم باید تا 20 مرداد بمونی توک ف!
فکرک نم تو هم مث خیلی ها بعد از خوندن پنج شماره بوم، متوجه شدی 

چطوری بیشترین بهره وری رو از توانایی هات داشته باشی.
تا حالا هم حتما پیشرفت خوبی داشتی.

پس بیشتر از این وقتت رو نمیگیرم تا خوندن این بوم رو هم شروعک نی و 
با بکار بستن توصیه ها و تجربیات حرفه ای تر ها! به جاییک ه میخواهی 

برسی. 
اینو بدونک ه آرزوی من و دوستانم سربلندی و موفقیت توئه...
خوبت  پیشنهادات  از  مارو  توهم  نمیذاریم!  تنهات  ما 

محروم نکن... منتظرما!  
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قلم موهای پروانه ای
قلم موهای توری
قلم موهای حباب

قلم موهای چشم هایک ارتونی
قلم موهای طرح خمیده و منحنی

اکشنی برای تبدیل تصاویر به مکعب
اکشنی برای صافک ردن پوست صورت
اکشنی برای ایجاد شیرازه های فنری

اکشنی برای دادن جلوی ای زیبا به تصاویر
اکشنی برای بیرون آوردن اشیاء ازک ادر
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نهایت خلاقیت درفتوشاپ

نهایت خلاقیت درفتوشاپ

"part 1"

"قسمت اول" 
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8 BOOM P R O F E S S I O N A L8

هر چه بیشتر با فتو شاپ انس بگیرید قطعا به فوت و 
فن های جدیدتری دست پیدا می کنیدک ه به خلاقیت در 
طراحیک مک موثری می نماید. در اینجا به تعدادی از این 
فنون جذاب اشاره شده تا از این برنامه فوق العاده نکات 

بیشتری یاد بگیرید.  
معمولا بسیار جالب خواهد بودک ه راه جدید و درعین 
حال ساده تری برای انجامک اری را یاد بگیرید، خواه این 
راه جدید یک میانبر برای انجام یکک ار و یا یک روش 

سریع تر برای انجامک ارهای روزانه باشد و

حس بسیار خوبی خواهید داشت زمانیک ه احساس 
کنید حتی ثانیه ای را از تلف شدن در گذر زمان نجات 
داده اید.و این حس مشخصا مر بوط به زمانی استک ه 
راه جدیدی در فتوشاپ برای انجامک ارهایتان فرا گرفته 
باشید. خبر مهمتر اینکه با هر ورژنی از فتو شاپک هک ار 
می کنید قطعا از این روش ها لذت برده و می توانید این 

فنون را بار ها و بار ها تکرارک نید.
یکی از بهترین نکات در موردک ار در این مجله این است 
که ما به عنوان یک تیم، تجربه ها ودلبستگی های متفاوتی 

از فتو شاپ داریم و این بدین معنی استک ه می توانیم 
بهترین راه برای انجام بعضیک ارها را به راحتی انتخاب 

نماییم. 
یک فرد ممکن است بعضی چیزها را با تمرکزک ردن و 
توجه به یک موضوع به هنگام خواندن یک مجله یاک تاب 
یاد بگیرد و یا می تواند با بد شانسی تمام از آن عبورک ند.
ما هرگز از تبادل اطلاعات و تجربه هایمان خسته نمی 
شویم و لذت می بریم از اینکه آن ها را با شما درمیان 
بگذاریم. در چند صفحه بعد فوت و فن هایی از فتوشاپ 
آموزش داده می شودک ه بهک مک آن ها می توان تصا ویر 

بهتروجذاب تری ایجاد نمود. 
در استفاده از میانبرها معمولا روش هایک م زمانتر به 
منظور بالا رفتن سرعتک ارهای معمولی و یا سادهک ردن 

یک عملیات مد نظر قرار می گیرد.
کسانیک ه از روتوش و یا دستکاریک ردن تصاویر لذت 
می برند قاعدتا به فنونیک ه به عکاسی مرتبط بوده و به 
آنها درک ار با تصاویر دیجیتالک مک خواهدک رد علاقه 

بسیار زیادی خواهند داشت.
هنرمندان دیجیتالی نیزک مک های بسیاری خواهند یافت 
چراکه در اینجا راههای جدیدتر و خلاقانه تری برایک ار با 
براش ها و دیگر ابزارها وجود دارد. به علاوه روش های 
وجود داردک هک مک می کند برنامه را بر طبق نیاز خود 

تنظیمک رده به طورک امل بر رویک ار تمرکز نمود. 
ما در اینجا این فوت و فن ها را دسته بندی نمیک نیم 
چراک ه امکان دارد بعضی از آنها در دسته بندی های 
مختلفی قرار بگیرد اما تمام آنها به طرق مختلف در نوع 
کارکرد و نتیجهک ار تاثیر گذار خواهد بود. بنابراین آرام 
باشید. و تمرک زک نید. در آینده ای نزدیک از این فنون 

درک ارهایتان استفاده می کنید.
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1-تغییرات را ببینید.
برای  ساده  راه  یک  شاپ  فتو  در  تایپ  ابزار  با  هنگامک ار 
تغییررنگ متن، انتخاب متن و دابلک لیک بر روی رنگ مورد 
دلیل های لایت شدن  به  اینجاستک ه  می باشد.مشکل  نظر 

متن نمی توان تغییرات رنگ را مشاهده نمود. 
برای حل این مشکل بر روی مربع رنگ در روی نوار تنظیمات 
)option(ک لیکک رده و رنگ مورد نظرتان را انتخابک نید.به 

راحتی تغییرات رنگ قابل مشاهده خواهد بود. 

2-مسیر آسان 
برای  مناسبی  بسیار  ابزار   )pen( قلم 
انتخاب نواحی در یک عکس می باشد. اما 
اشیاء  برای  مناسبی  ابزار  مغناطیسی  قلم 
لبه های  به  طوریک ه  به  می باشد  ساده تر 
یک  آسانی  به  و  چسبیده  نظر  مورد  شی 
  freeformمسیر را به وجود می آورد. قلم
انتخابک رده و سپس در نوار تنطیمات بر 
  Custom shape روی فلش درک نارآیکون
زدن  با  قسمت  این  در  نمایید.  کلیک 
فعال  را  مغناطیسی  گزینه  نظر  مورد  تیک 

نمایید. 

3- لایه های پر از شکل
Custom shapeها  می دانید  همانطورک ه 
ابزار های بسیار مناسبی برای گرافیک برداری 
shape استفاده  هستند هر زمانک ه یک ابزار 
مسیر  و   shape با  همرا  جدیدی  لایه  می شود 
نیاز   shape به  فقط  چنانچه  اما  می آید.  بوجود 
داشته باشید بر روی آیکون fill pixels )سومین 
تنظیمات(ک لیک  نوار  در  چپ  سمت  از  آیکون 
نمایید.بدین ترتیب فقط shape خواهید داشت 
و با این روش می توانید shape های مختلفی را 

در یک لایه قرار دهید. 
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4- یک چشم بر هم زدن 
برای داشتنک نترلک امل بر روی تصویر ساخت لایه برای هر قسمت جدید ازک ار حیاتی به نظر می آید. اگر چه این 
از لایه های مختلفک می  پر  با یک لیست  اما سر وک له زدن  اختیارتان قرار می دهد  را در  کارک نترل های مختلفی 
خستهک ننده به نظر می رسد.اگر بخواهید تنها بر روی یک لایه تغییراتی را اعمال نمایید و نمی خواهید لایه های 
دیگر تحت تاثیر این تغییر قرار گیرند و یا لایه های دیگر باعث سر در گمی شودک لید Alt را نگه داشته و بر روی 

چشمک ناری همان لایهک لیک نمایید.تمام لایه های دیگر پنهان خواهند شد.

5 - زوایای تند 
یک  بخواهید  استک ه  زمانی  برای  ساده  روش  یک  این 
نظر خود  باشد. عکس مورد  زاویه خاص  عکس دارای یک 
منوی  )در  انتخابک نید.  را   measure ابزار  و  بازک رده  را 

قطره چکان( 
یک خط با زاویه مورد نظرتان رسم نمایید.حال مسیر زیر را 

دنبال نمایید.
رسم  خط  به  نظر  مورد  لایه   Edit> Transform> Rotate

شده می چسبد.

BOOM P R O F E S S I O N A L10
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6- سوزاندن پایین خانه
یک راه سریع برای بدست اوردن یک 
آگهی های  در  معمولا  اشباعک ه  تصویر 
تجاری دیده می شود استفاده از حالت 
color burn درقمسمت تریکب لایه ها 
حالت  است.این   )blending mode(
تصویررا تیره ترکرده وک نتراست را بالا 
برده و به نظر برای عکس مناظر مناسب 
می باشد. از روی عکس اصلی یک لایه 
روی  بر  را  لایه  حالت  و  بسازید  کپی 
نتیجهک ار  و  دهید  قرار    color burn
بود  بالا  رنگ  چنانچه شدت  ببینید.  را 
می توان باک اهش opacity یا شفافیت 
تصویر به حالت دلخواه دست یافت. 

BOOM P R O F E S S I O N A L11

7- تبدیل وک پی 
گاهی اوقات می خواهید یک تصویر را بیش از یک 
بار درک ار خود بهک ار ببرید. و شاید هم سایز یا 
زاویه آن را تغییر دهید. به جای ساختن چند لایه 
و انجام عملیات دستیک لیدCtrl+Alt+T را فشار 
داده و سپس از ابزار تبدیل استفاده نمایید.عمل 
تبدیل بر رویک پی تصویر اعمال میشود و تصویر 

اصلی دست نخورده باقی می ماند. 

www.IrPDF.com

www.IrPDF.com www.IrPDF.comwww.IrPDF.com



8- پالت ها بیرون !
زمانیک ه درگیر یکک ار جدی ویرایش 
تصویر هستید ممکن است پالت های باز 
زیادی درمقابل شما باشد و تمام محیط 
اطراف را فرا گرفته باشند.این شرایط 
برای زمانیک ه می خواهید نتیجهک ارتان 
چندان  دنبالک نید  لحظه  به  لحظه  را 
نباشید.ک افی  نگران  نیست..  مناسب 
استک لید tab را فشار دهید. پالت ها 
مخفی شده و با فشار مجددک لید به جای 

خود باز می گردند.

9 - مرکز خود را پیداک نید!
شی  یک  مرکز  پیداک ردن  برای  خوب  ترفند  یک  این 

می باشد. مسیر زیر را ادامه دهید. 
به  باکس  یک  هنگام  این  در   Edit >Free Transform
دور شی مورد نظر اضافه میشود.ک ه وسط آن به وسیله 
lView > Ru  دایره ای مشخص می باشد.سپس به مسر ی
ers رفته و سپس خطوط راهنما را به سمت باکس در بر 

گیرنده بکشید.

 )textures( 10 – استخراج بافتها
فیلتر استخراج )Extract( ممکن است خواسته شما ازیک ابزار برش خیالی باشد. در اینجا راهی 
Extractهستید  فیلتر  واسط  قسمت  در  مشغولک ار  دارد.وقتی  وجود  اینک ار  سادهک رده   برای 
 )Filter> Extract( نگاهی به پانل سمت راست بیاندازید. در قسمت استخراج یک چک باکس به نام
 Textured image قرار دارد. با زدن تیک این قسمت ابزار بوسیله امتحان بافت، لبه ها را جستجو خواهد کرد.  

BOOM P R O F E S S I O N A L12

curves -11 یا منحنی ترسیمی 
ابزار curves ابزار بسیار مناسبی برای ایجاد هماهنگی در تصویر می باشدک ه به وسیله آن می توان به سادگی 
جلوه های مختلفی بر تصویر ایجاد نمود. به علاوه برای ویرایش تمامی تصویر می توان از منویک شوییک انال 
یکک انال رنگ مخصوص را انتخابک رد. به هر حال قادر خواهید بودبا انتخاب رنگ مورد نظر تمرکز خود را 
 Ctrl را بازک رده و سپس با نگه داشتنک لید curves قرار دهید. پالت curves بر روی یک رنگ در منحنی
بر روی رنگ مورد نظر در تصویرک لیکک نید. نقطه ای بر روی منحنی نمایان میشودک ه نشانگر همان رنگ 

مورد نظر بر روی منحنی خواهد بود.
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)Shape Paths ( 12- پنهانک ردن مسیر اشکال
همانطورک ه می دانید زمانیک ه یک شکل به وسیله ابزار Shape tool ترسیم می شود 
یک لایه شکل به همراه مسیری به دور شکل ایجاد می گردد. در هر حال به غیر از زمان 
ویرایش مسیر دلیلی برای دیدن این مسیر وجود ندارد و در اغلب اوقات حضور این 

مسیرک می ناخوشایند به نظر می رسد. 
همانطورک ه قطعا حدس زده اید در این جا یک راه حل بسیار جالب برای اینک ار در نظر 

گرفته شده است.
بعد ار ترسیم شکلک لید تریکبی Ctrl+Shift+H  را فشار دهید. به این ترتیب مسیر 
دیدن  به  نیاز  مسیر  ویرایش  منظور  به  نیست.چنانچه  رویت  قابل  ودیگر  پنهان شده 

مجدد مسیر داشتیدک افی است دوباره همانک لید های تریکبی را فشار دهید. 
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13- از تاریخ بیاموز !
برای  ناجی  یک   )History( تاریخ  پالت 
زمانهایی است نظرتان برای اعمال تصمیمی 
تغییرک رده و نیاز دارید چند مرحله به عقب 
از  قسمتی  می توان  چگونه  گردید.اما  باز 
تصویر را به حالت اولیه برگرداند در حالی 
که مابقی تصویر بدون تغییر و دست نخورده 

باقی بماند؟ 
موثر  می تواند  پاکک ن  اینجاستک ه  خوب 
در  و  انتخابک رده  را  پاکک ن  باشد.ابزار 
را   Erase to History گزینه  تنظیمات  نوار 
مورد  بر قسمت  پاکک ن  با  و  انتخابک نید 
شدن  جایگزین  جای  به  حرکتک نید.  نظر 
تغییر  بدون  اصلی  عکس  زمینه  پس  رنگ 

جایگزین خواهد شد.
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14- آزادی در تولید مثل !
از  یافتن  رهایی  و  تصاویر  ویرایش  برای  خوب  بسیار  راه  یک    clone ابزار 
مشکلات می باشد. چه می توانک رد اگرنتوانید یک ناحیه مناسب در تصویر منبع 
بیابید در حالیک ه یک ناحیه بسیار بزرگ در تصویر دیگر دارید. ساده است. 
تولید آن.اگردرآن واحد دو تصویر باز شده وجود داشته باشد ابزار clone را 
برداشته و با نگه داشتن دکمه Alt بر روی قسمتیک ه می خواهید از روی آن 
بسازیدک لیک نمایید.حال به تصویر دوم رفته و شروع بهک شیدن نمایید.از این 
روش می توان برای خلق یک موضوع هم استفادهک رد.به عکس ها دقتک نید 

چهره دختر در بالا می تواند به عنوان جایگزین در عکس بالا استفاده شود. 
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15 – پالت معلق براش 
هنگامیک ه به شدت مشغول خلق تصاویری با 
استفاده از براش ها هستید یکی از بزرگترین 
دردسرها مراجعه مداوم به پالت براش ها به 
منظور تغییر براش یا افزایش وک اهش قطر 
حل  راه  یک  جا  این  در  اما  می باشد.  براش 
ماهرانه را خواهید دید. بر روی سند خودک لیک 
راستک نید. پالت براش ها نمایان می شود. 

"ادامه دارد..."
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گفتگو با 
محمدحسن آزادگان
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باید اعترافک نمک ه آقای محمد حسن آزادگان رو بعد از 
یک هفته وقت گرفتن خیلی اتفاقی پیداک ردم و در همین 
شرایط مصاحبه رو به صورت غافلگیرانه انجام دادم! نتیجه 

این مصاحبه رو با هم می خونیم...

معرفّی!
محمّدحسن آزادگان، متولدّ خرداد 1365، فرزند دوم 
خانواده، از شهر تهران، دیپلم ریاضی، مشغول تحصیل 
در رشته آموزش زبان انگلیسی دانشگاه علمیک اربردی 
تهران واحد 35، در حال حاضر شغل ثابت ندارم ولی برای 

چند تا موسّسه به صورت پروژه ایک ار میک نم. 
داری ترم چند رو می گذرونی؟

 پودمان ششم، پودمان یه چیزی شبیه ترمه.
ازک ی به گرافیک علاقه مند شدی؟

دقیقا یادم نیست. شاید از خیلی سال پیش ولی یادمه 
که از وقتی با امکانات رایانه برای تصویرسازی آشنا شدم 
فکر  احساسک ردمک ه  رو  زدگی شدید  ذوق  یک جور 
می کنم همون باعث شد خیلی به گرافیک اهمّیت بدم.

تقریبا از چند سالگی؟ یا چند سال پیش؟
حدود 6-5 سال پیش،17 سالگی.

منابع آموزشیت در زمینه گرافیک چیه؟
برای رایانهک ه فکر می کنم هیچی. ولی دروسیک ه در دوره 
کنکور هنر خوندم خیلی تو تصویر سازی به دردم خورد.

کنکور هنر دادی؟
بله، دو بارک نکور دادم.

قبول نشدی؟
چرا رشته نقاشی دانشگاه سوره قبول شدم ولی خوب 

نرفتم.
چرا نرفتی؟

 راستش احساس خوبی نسبت به این رشته نداشتم من 
حتی در آزمون عملی هم قبول شدم ولی دیدم، نسبت 
به این رشته این بودک ه باید تصویرسازی رو از اول با 

ابزارهایک لاسیکک ارک نیم.
گفتی پروژه ایک ار مکینی،ک ارهای گرافکیی؟

با  تصویر  یه  و  بشینیم  فقط  اینکه  نه  ولی   بله، 
Photoshop بسازیم و اسمش رو بذاریم پروژه! آخرین 
کاریک ه هنوز هم مشغولش هستیم، یک مجموعه تبلیعاتی 

برای یه شرکت واردات تجهیزات آزمایشگاهی بوده.
درآمد خوبی هم از این راه در میاری؟ 

راستش باید بگم نه… البته درآمدش برام مهم نیست 
من یه تازهک ارم و تجربه زیادی در این زمینه ندارم، من 
بیشتر روی رشدیک ه دارم می کنم حسابک ردم اگر به 
قول شماک ار راضیک ننده باشه طرفدارهای بیشتری پیدا 

مکینه؛ همین باعث میشه توک ار رشد داشته باشی.
خوب چرا در زمینه گرافیک ادامه تحصیل نمیدیک ه 

زودتر موفق شی؟
سوال خیلی خوبی بود. من به این جور سوالات میگم 
سوالات فلسفی!اولین دلیلیک ه ادامه ندادم این بود 
که خانواده ام زیاد با تحصیل تو یه رشته هنری موافق 
نبودن؛ بعد هم ابتدا فکر مکیردم برای گرافیست شدن 
لزومی نداره حتما اصول و روش خاصی یاد بگیریم وک ار 
بیشتر سلیقه ایه. البته هنوزم اعتقاد دارم گرافیک اصول 
و قانون خاصی نداره ولی درعین حال برای صاحب سبک 
بودن و داشتن حرفی تو این زمینه تحصیلات دانشگاهی 

الزامیه.
یعنی الان واسه خودت سبکی نداری؟ طوریک هک ارات رو 

متمایزک نه؟
هنوز نه، البته همهک ارهام یه خصوصیات خاصی داره مثلا 

A R T I S T SBOOM18

www.IrPDF.com

www.IrPDF.com www.IrPDF.comwww.IrPDF.com

http://photo-art.mihanblog.com



از بافت زیاد استفاده می کنم یا به تصاویرک نتراست پایین علاقه ندارم، ولی به نظرم 
نمیشه به اینجور چیزها گفت سبک.

چرا خانواده ات موافق ادامه تحصیلت تو این رشته نبودن؟ الان از شغلت راضی 
هستن؟

دلیل عدم موافقتشون رو هنوز هم نمی دونم. در حال حاضر مخالفتی باک اریک ه 
می کنم ندارن. ولی عکس العملی هم نسبت بهک ارهام نشون نمیدن. تصورّم اینهک ه 

بیشتر به رشته ایک ه تو دانشگاه میخونم امید دارن!
الان از رشته دانشگاهیت راضی هستی؟ دوست داری شغل آینده ات وابسته به 

کارهای گرافکیی باشه یا رشته زبان؟
البته باز هم سوال یه مقدار پیچیده بود! من به هر دو رشته علاقه دارم هم زبان و 

هم گرافیک ولی هدفم رو بیشتر روی گرافیک متمرکزک ردم.
یک روز محمد حسن آزادگان چطور می گذره؟ چهک ارهایی در طول روز می کنه ؟

 در طول هفته برنامه های روزانه ام متفاوته، یعنی روزهاییک ه دانشگاه میرم 
بیشتر وقتم تو همین مسیر رفت و برگشت تلف میشه، روزهایی همک ه خونه 
هستم بهک ارهای عقب افتاده ام می رسم و سعی می کنم اگر وقت داشتم یه 

سری به اینترنت بزنم و اگر وقت اضافی داشتم یه مقدار با نرم افزارها و 
بقیه ابزارها تمرینک نم.

طول هفته گرافیکک ار مکینی؟یا برای گرافیک برنامه ویژه ای داری؟ 
هر موقعیک ه احتیاج باشه گرافیکک ار می کنم، البته قبلا خیلی برای اینک ار وقت 
می ذاشتم و بیشتر تصاویر شخصی می ساختم و برای وبلاگم مطالب آموزشی می نوشتم. 

ولی حالاک متر پیش میادک ه برای این جورک ارها وقت بذارم.
اون روز چه احساسی داری ؟
احساس خیلی خوبی دارم !

شده تا حالا ازک اریک ه انجام میدی راضی نباشی ؟
بله از هیچک دوم ازک ارهاییک ه زدم راضی نیستم!

چرا؟
دوست دارم خیلی بیشتر از این پیشرفتک نم. اگر بشینم و برای اینک ارها به خودم 

افتخارک نم مسلما حاضر نیستم برای رشدک ردن به خودم سختی بدم.
پس با خودت رقابت می کنی!

بله، یه همچین چیزی!
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طرح هاتو به صورت دستی انجام میدی؟
تا حالا شده دستی همک ارک نم یعنی طرحی رو رویک اغذ 
بکشم و اسکنک نم و ازش استفادهک نم ولی این اتفاق 
به ندرت افتاده، جدا از اینکه طراحی دستی ام خیلی خوب 
نیست و این هم یکی دیگه از عواقب تحصیل نکردن تو 

رشته گرافکیه!
با چه نرم افزاراییک ار مکینی؟

 روی نرم افزار خاصی تعصّب ندارم. تقریبا با هرچیزی 
که بتونم با اون، به تصویریک ه دوست دارم برسم،ک ار 
می کنم. نود درصد تصاویر رو با Photoshop می سازم.

احساس می کنم اعتماد به نفس نداری؟
نه، چرا شما این فکر روک ردی؟

آخه اصلا ازک ارات راضی نیستی! فکر نمیک نی اگه خوب 
نبود، هیچ سفارشی هم نداشتی؟!

بله، ولی اینجا باید تفاوتی بین خوب بودنک ار و راضی 
بودن ازک ار قائل بشیم، اینکه گفتم من ازک ارهام راضی 
نیستم معنیش این نیستک ه ازک ارهام بدم میاد اتفاقا 
کارهام رو خیلی دوست دارم، حتی ازک ارهای موفّقم ایده 
میگیرم برایک ارهای جدید؛ ولی اعتقاد دارم همیشه 

باید به پیشرفت فکرک رد.
می دونیدک ه اینک ار جای رشد و پیشرفت خیلی داره 
و من همیشه سعی می کنم ازک ارهای افرادیک ه از من 

قوی ترک ار مکینن الگو بگیرم.
از چه افرادی الگو می گیری؟

حقیقتش از فرد خاصی الگو نمیگیرم، شاید تنها شخصی 
که برای ساخت تصویر ازش الگو گرفتم آقای نجابتی 
بودهک ه چند طرح تایپو گرافیک ه زدم رو از ایشون ایده 
گرفتم. جدا از این مورد، به نظرم در ساخت تصاویر 
الگو گرفتن از یک شخص خاص اشتباهه. این روزها 

ابزارهای گرافیک در دسترس همه هست و فقطک افیه 
خلاقیت داشته باشی و زحمت بکشی. من حتی دوستان 
نوجوانی رو دیدمک ه ایده های خیلی خوبی برای تصویر 
سازی داشتن و مهارت استفاده از ابزارها رو همک سب 
کردن و در نتیجهک ارهای فوق العاده ای ساختنک ه هر 
کسی میبینه تصور مکینه این تصاویر توسط یک شرکت 
تخصّصی گرافیک با چندین سال سابقهک ار طراحی شده. 
پس نمیشه زیاد روی اسم و رسم تیکهک رد. به همین 
خاطر من هم همیشه سعی می کنم بدون توجه به اسم 

طراح، از بهترین طرح ها استفادهک نم.
از  یا  مکینی  مستقلک ار  صورت  به  تصویرسازی  تو 
تصاویریک ه دیگران قبلا ساختن هم استفاده می کنی؟

خوب مسلمه بیشترک ارهای گرافکییک ه انجام دادم 
به صورت تریکب تصاویر خام و اولیه هست،البته این 
بستگی به بعضی شرایط هم داره مثلا بعضی سفارشها 
خیلی سطحی و بی اهمیته، حتی سفارش دهنده هم 
ارزش زیادی برایک ار قائل نیست! در این جورک ارها 
من وقتم رو تلف نمیک نم و از تصایر ازپیش ساخته 
شده استفاده می کنم. ولی دربعضی پروژه های با اهمیت 
و همینطور تصاویر شخصی خودم، حدودا نود الی صد 

درصدک ار رو خودم می سازم.
از چه چیزهایی برای طراحی ایده میگیری؟

تقریبا هیچی! تمام تصایر ذهنی ساخته میشه؛ البته از 
کارهای دیگران هم ایده می گیرم مثلا همیشه تو اینترنت 
گشت می زنم و دنبال قوی ترینک ارهاییک ه ساخته شده 
می گردم ولی هیچ وقت به صورت مستقیمک ارم رو از 

جایی الگو برداری نمیک نم.
میشه در مورد گرافیک دیجیتال یهک م توضیح بدی؟

یعنی براتون تعریفشک نم؟
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بله، هر چی در موردش می دونی بگو بیشتر آشنا بشیم!
باشه، اطلاعاتیک ه در مورد گرافیک دیجیتال دارم عموما 
به صورت تجربیک سبک ردم ذهنیتم از گرافیک دیجیتال 
اینهک ه: گرافیک دیجیتال یعنی ساختن تصاویر با استفاده 

از ابزارهای رایانه ای.
اگه باز به دنیا بیای، میری طرف گرافیک یا نه؟ 

این سوال رو خیلی زود ازم پرسیدید. در حقیقا من الان 
تازه دارم میرم طرف گرافیک. اگرهم دوباره به دنیا بیام 
تصورّم اینهک ه بازم به دنبال اینک ار برم. شاید یهک م 
خنده دار باشه ولی یادمه از وقتی خیلیک وچیک بودم، هر 

وقت ازم می پرسیدن »میخوای چکیاره شی؟«، می گفتم قصد دارم نقاش بشم!
برای موفقیت طراح های تازهک ار نظر ت چیه؟ازک جا شروعک نن؟

سوالای سختی می پرسید! راستش اولویت برای انتخاب این راه تحصیل در این رشته 
است. داشتن مدرک و اینکه سه چهار سال در فضاهای هنری قرار داشته باشی و با 
اصول هنر آشنا بشی خیلی موثرّه، اما اگرک سی می خواد مثل من به صورت تجربی و با 
استفاده از رایانهک ار یاد بگیره بهترهک ه اول 
خوب باک اربرد ابزارهای رایانه آشنا بشه؛ 
بعدک مک م شروعک نه به ساخت ایده ها و 
پیادهک ردن تصاویریک ه تو ذهنش شکل 
میگیره. در مجموع به نظر من گرافیست 
شدنک ار ساده ای نیست و به هیچ وجه 
کسب درآمد نمیتونه انگیزه مناسبی برای 

اینک ار باشه.
علاقه چی پس؟ اونیک ه علاقه داره یعنی 

نمی تونه موفق بشه؟
خیلیک مک  داشتن  دوست  اتفاقا  چرا! 

مکینه.
اگه ایران نبودی، حاضر بودی واسه خرید 

Photoshop 1000 دلار بدی؟

 وای چه سوال سختی!
...مسلمّا  نه! چون من هنوز از Photoshop CS استفاده 
می کنم و فکر می کنم برای خریدش لازم نباشه اینقدر 

پول بدم!
خوب فرضک ن خارج هستی و به اندازهک افی پول داری، 
بازهم حاضر نیستی اینک ارو انجام بدی؟ آینده هم داره، 
خوب خرج اولیه می کنی ولی بعدا چندین برابرشو در 

میاری!
نه،چی بگم؟ خوب حاضر نیستم !

اینترنت،  طریق  از  میشه؟  پیشنهاد  بهتک ار  چطوری 
دوست، آشنا، وبلاگ؟

حقیقتش من خیلی تنبلم! هیچ تلاشی نمیک نمک ه در مورد تواناییم تبلیغک نم یا دنبال 
مشتری بگردم. تا به حال تمام مشتری ها به صورت اتفّاقی از اینترنت با من آشنا 

شدن یا اینکه از اقوام و دوستان بودن.
نمی خوای یه سایت واسهک ار راه اندازیک نی؟
دوستان  از  یکی  البته  ندارم.  قصد  فعلا 
خیلی   - محمّدی  محمّد  آقای   - گرافیستم 
اصرار داشتک ه اینک ار رو با هم انجام بدیم 
و یک سایت تخصّصی داشته باشیم. ولی هنوز 

فرصت پیش نیومده.
چند تا از سایت هاییک ه به نظرت مفیده رو 

معرفیک ن!
دیدم  سایت هاییک ه  مفیدترین 
گرافیک  ابزارهای  برای  منبع  سایت های 
آرت دوینت  سایت  بهترینشون   بودهک ه 
)DeviantArt.com( هستش؛ بعلاوه انجمن های 
هم   Sohail2D انجمن همین  مثل  تخصّصی 
خیلی مفیده، از اخبار مجله اینترنتی رنگ هم 

استفاده می کنم.
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منابعت واسه یادگیری چیه، اینترنت یا...؟
اینترنت خیلی بهمک مکک رده مخصوصا تو جمع آوری ابزارهای گرافیک؛ ولی آموزش هایک اربردی 

زیادی تو اینترنت ندیدم.
منظورت آموزش های فارسیه یا خارجی؟

خوب آموزش های سایت های خارجی بهتر بوده چون بیشتر فعالیت دارن.
پس بیشتر از منابع خارجی استفاده می کنی...

نمیشه گفت، چون همون طوریک ه گفتم به طورک لی اینترنت برام منبع آموزش نبوده.
پس منبع اصلیت چی بوده؟

اکثر توانایی هام رو به صورت مستقل خودمک سبک ردمک ه فکر می کنم خیلی هم زیاد نبوده.
کتاب و مجلات چی؟ از اون ها به عنوان منبع استفاده مکینی ؟

بله؛ البته سوالتون یه مقدار پیچیده ست! همه چیز رو به هم ربط دادید!
خوب هر جور خودت دوست درای بگو...

باشه؛ من سعی می کنم با توجه به شرایط محیط اطرافم پیشرفتک نم. سعی می کنم با توجه به خواسته ها 
و سلیقه ها تصویر بسازم. اینکه بدونیم مقصودمون از ساختن یه تصویر خاص چیه خیلی مهمه. شاید 

عمده ترین منبع آموزشی من همین بوده. 
در زمینه گرافیک دوست داری بهک جا برسی ؟

ایده آلم در گرافیک اینهک ه یک استودیو و تیمک امل برای ساخت انوع تصاویر اعم از تصاویر ساده، 
انیمیشن، تولید نرم افزارها و حتی ساخت فیلم داشته باشم.

گپی خودمانی با محمد حسن در زمینه انجمن های Sohail2d و ماهنامه گرافکیی بوم 
نظرت در مورد سایت Sohail2D چیه ؟ چه جوری ارزیابی اش می کنی ؟

سایت Sohail2D رو خیلی دوست دارم. سایت خیلی جالبیه؛ من احترام زیادی برای آقای صالحی قائلم. مطالبیک ه تو 
سایت مینویسن خیلی جالبه، انجمن خیلی خوبی هم داره ولی احساس می کنم فعالیت انجمن اونقدریک ه باید باشه 

نیست.
خوب دوستانی مثل شما ما رو زیاد به فیض نمی رسونن! دوست داری چه تغییراتی تو انجمن انجام بشه؟

راستش احساس می کنم اگر مباحث تخصّصی بیشتری مطرح بشه وک می هم تبلیغات درباره این انجمن داشته 
باشید فعالیت بهتر میشه. در ضمن فکر می کنم یه ظاهر جدید برای انجمن تاثیر خیلی خوبی داره.

به نظرت بوم تبلیغ خوبی نیست برای انجمن؟
نه، فکر می کنم تقریبا تمامک سانیک ه با بوم آشنا هستند و اون رو میخونن با این انجمن هم آشنا هستندشاید 

اگر در سایت های دیگه تبلیغ بشه بهتر باشه.
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شات  و  بوم  مجلات  ندیدی؟  رو  بوم  بازخورد 
دریافت  بار  هزار   400 حدود  چیزی  الان  تا 

شدن
نمکیردم  فکر  اصلا  من  عالیه  خیلی  واقعا؟ 
اینقدر خواننده داشته باشه. چون شماره های 

قبلی رو از خود انجمن گرفتم.
بوده.  خوب  بازخوردش  الان  تا  شکر  رو  خدا 

نظرت در مورد بوم چیه ؟
مطالبش  یک فیت  جالبه، خیلی  برام  بوم  مجله 
هم در حد خوبیه، خصوصا اینکه تو شماره های 
اخیریک فیت مجله خیلی بهتر شده، به نظر من 
اگر روی جلد مجله بیشتر وقت گذاشته بشه 

تاثیر خیلی خوبی تو بازخورد مجله داره.
داری؟ک جاهاش  انتظاراتی  چه  بوم  مجله  از   
تغییرک نه بهتره؟ چه چیزهایی بهش اضافه یا 

ازشک م بشه ؟
اگر  دارم  دوست  خیلی  رو  گالری  بخش  من 
همراه با توضیح باشه یا مثلا از آثار یه نمایشگاه 

استفاده بشه خیلی بهتره.
سوء  ازک ارت  بودی  گفته  انجمن  تو  یادمه 
استفاده شده... چرا باید اینک ار انجام بشه؟
بله... اینکه چرا باید این اتفّاق بیفته رو باید 

ازک سانی بپرسیدک ه اینک ار روک ردن.
استفاده  سوء  ازک ارات  یاک سانی  چهک سی 

کردن؟
نمیتونم بگم... بیشتر سوء استفاده ای  دقیقا 
وبلاگ  بودک ه  دوره ای  تو  ازک ارهام شده  که 
داشتم اون موقع با این جور سوء استفاده ها و 
زیاد آشنا  اینترنتی  برداری های غیرمجاز  کپی 

نبودم و خیلی راحتک ارهام رو بایک فیت خوب در وبلاگ قرار 
میدادم.

وقت  روش  دیدیک اریک ه  وقتی  پیداک ردی  احساسی  چه 
گذاشتی به اسم دیگه ای چاپ شده؟

حقیقتا دلگیر شدم مخصوصا موقعیک ه مجلهیک هان ورزشیک ار 
من رو بایک فیت خیلی پایین و با ویرایشک املا غیر حرفه ای به 

صورت تمام صفحه روی صفحه اول مجله چاپک رده بود!!
ازک جا متوجّه شدیک ه ازک ارات سوء استفاده شده؟

وقتی  و  دیدم  فروشی  روزنامه  تو  رو  مجله  خودم  متاسفانه 
متوجه این موضوع شدم حدس زدمک ه احتمالا خیلی جاها از 
اتفاقی  به صورت  من  و  شده  سوء استفاده  تصاویرم  از  خیلی 

فقط یکی از اون ها رو دیدم...
یادمه یه بار هم تو یکی از مسابقه های انجمن برنده شدی... 

انتظار داشتی نفر اول بشی؟
نه، اصلا ! یکی از دوستان خیلی عزیزم در مسابقه شرکتک رده 

بود، به نام علی پوربافرانیک ه نفر دوم شد. 
بعلاوه  بود  طرح  بهترین  ایشون  طرح  نظرم  به 
اینکه آقای بهرام ارجمند نیاک ه یک گرافیست 
و هنرمند بزرگ هستن هم تو مسابقه شرکت 

کرده بودن.
بهترین خاطره ایک ه از انجمن داری چیه؟

شاید بهترینش ملاقات با مصطفی ناصحی عزیز 
بود.

اگه بخوای با یکی از اعضای انجمن پروژه ای رو 
انجام بدی، دوست داری اون فردک ی باشه؟

و  بیفته  اتفاق  این  دارم  دوست  خیلی  من 
واقعا جزو افتخارات من محسوب میشه، من به 
کارهای امیر، رامین، فرانک خانم، پژمان عزیز 
و چند تا دیگه از دوستانک ه اسمشون خاطرم 
قرار  اگر  ضمن  در  دارم  علاقه  خیلی  نیست 
اولین  بدم  همکاری  پیشنهاد  بهک سی  باشه 

شخص خود آقای صالحی هستن.
حرف  عنوان  به  بزن  داری  دوست  حرفی  هر 

آخر...
وتمام  شما  از  فقط  ندارم  خاصی  صحبت 

همکارانتون در مجله بوم تشکر می کنم.
حرف آخرم رو هم به خواننده های مجله عرض 
سلیقه  باشیدک ه  این  پی  در  همیشه  می کنم: 
دیداری خودتون رو بهترک نید. مطمئن باشید خوب 

دیدن روی خوب زندگیک ردن تاثیر میذاره!
برای دیدن آثار بیشتری از این هنرمند، به دو 

آدرس زیر مراجعهک نید: 
 http://forum.sohail2d.com/viewtopic.php?t=10389

http://photo-art.mihanblog.com
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فیل استراب ) Phil Straub( یک دهه استک ه در زمینه ی هنرهای دیجیتالی به صورت حرفه ای فعالیت می کند و پیش 
از اینکه به گرافیک رایانه ای روی بیاورد، نقاشی رنگ و روغن و آکریلیک را آموخته است. او همچنین با پاستل، آبرنگ 

و ذغال نیزک ارک رده است.
وی می گوید: »همکاری اول من، با نویسنده ی شهیرک تاب هایک ودک، Mercer Mayer بود...« و چنین ادامه می دهد:

»وقتی من به استودیو رفتم، او داشتک تاب های خود را به وسیله طراحی های اسکن شده و بهک مک Photoshop و 
Illustrator، تهیه می کرد.«

»من آرام آرام این روش را با سبک خودم تریکبک ردم تا به تریکبات و نتایج تازه تری دست یابم. این روزها من تقریبا 
همه یک ارهایم به صورت دیجیتالی بوده و دستم بسیار بازتر است.«

این روزها، Straub به عنوانک ارگردان هنر مفهومی در Electronic Arts مشغول بهک ار است و بر روند تهیه هنرهای 
مفهومی نظارت دارد. مزیت ابزارهای دیجیتالی، انعطاف پذیری زیادشان استک ه آن ها را برای تولید محصولات هنری، هنر مفهومی و تصویرسازی بسیار ایده آل 
می سازد. در اوقات فراغت، Straub در زمینه های بسیار متنوعی – از نقاشی های سفارشی و دیواری گرفته، تا طراحی لباس – کار می کند؛ اگرچه، هنوز هم زمینه 

مورد علاقه او هنر فانتزی وک ارهای علمی- تخیلی است.
او برای خلق آثارش، در وحله ی اول به سراغ Corel Painter،Adobe Photoshop و Autodesk Maya می رود.

به عقیده او، »هیجان انگیزترین جنبه خلق آثار دیجیتال، امکانات نامحدودی ستک ه نرم افزار در اختیار هنرمند قرار می دهد. این موضوع می تواند از طرفی مفید 
و از طرفی دردسر ساز باشد : هیچ وقت نمی شود پایانک ار را تشخیص داد؛ چون می توان اصلاح و بازبینی آن را تا ابد ادامه داد!«

بنابراین، Straub گاهی اوقات به سراغ هنرهای سنتی هم می رود؛ اما نه به آن اندازهک ه دلش می خواهد: »دلم برای بوی رنگ و روغن تنگ شده است!«
علاوه بر تصویرسازی دیجیتالی، Straub به تولید محتوا برای بازی های رایانه ای نیز می پردازد؛ و نقاشی دیواری،ک تاب های تصویری، تصاویر ثابت )غیر متحرک( و 
طراحی پارچه را نیز تجربهک رده است. در ادامه، تعدادی از آثار او را مرور می کنیم. برای آشنایی بیشتر با Straub و آثار او، به وب سایت شخصی او مراجعهک نید: 
 http://www.philipstraub.com/Concepts.htm

معرفی هنرمند: 
)Phil Straub(فیل استراب
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نور بعد از ظهر:
یکی ازک ارهای مورد علاقه او در زمینه »مناظر فانتزی« ؛ در این اثر بسیاری از تکنیک های معمول در matte-painting بهک ار رفته است؛ تکنیک هاییک ه امروزه 

در ساخت فیلم ها بهک ار می رود. این تصویر با استفاده از Maya، Photoshop و Corel Painter ایجاد شده است.
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پازل چهره :
چاپ  هنری  مجموعه های  از  بسیاری  در  اثر  این 
برای  را  Electronic Arts آن  اخیرا،  و  شده است 
مجموعه ی آثار شرکتی خود خریداریک رده است. 
این اثر با رنگ و روغن، آکریلیک، ذغال و در نهایت 

با Photoshop خلق شده است.

یکپارچه :
Straub در آن تدریس  و نیز برایک لاسیک ه   – که در دست چاپ است   – نقاشی زیر برایک تابی 

می کند در نظر گرفته شده و با Corel Painter و Photoshop ایجاد شده است.
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روز جزا:
Straub این اثر را برای یک مجله ی گرافیک دیجیتالی ساخته است و برای 
ساخت آن، از تریکب نرم افزارهای دو بعدی – نظیر Corel Painter – و نرم 

افزارهای سه بعدی استفادهک رده است.

جاییک ه ترس پرسه می زند:
یکی دیگر از آثار مورد علاقه یک لکسیونرهای آثار او؛ این اثر، یکی دیگر از 

احساسات آدمی را به تصویر می کشد: ترس!
یادداشت خود هنرمند بر این اثر: »قضاوت عموم در مورد این اثر بسیار 
مطلوب بود! چاپ آن در مجلات Expose' 3 و Specturm 12 وک سب رتبه دوم در 

مسابقه سالانه تصویرسازی لس آنجلس!«
برای ساخت این اثر، Straub از Maya ,Corel Painter و Photoshop استفادهک رده 

است.
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حتما تا حالا شده که مطلبی رو بخونی و بعد از خوندنش، احساس کنی که فرق زیادی 
با قبل از خوندن نکردی! خب، بعدش چیکار کردی؟! تا چند وقت مطالعه رو به کل 
این  از  استفادهای  با خودت فکر کردی که »چرا هیچ  نه؛ نشستی  یا  کنار گذاشتی؟! 

نوشته نکردم؟«
...شاید این مساله دلایل زیادی داشته باشه، اما فکر می‌کنم یکی از بهترین دلیل‌ها رو 

»ژوزه سارماگو« در رمان »دخمه« اش آورده باشه :
»عده‌ای حتی یک عمر میخوانند، اما هرگز از حد متن فراتر نمیروند. آن ها به صفحه 

میچسبند و نمیدانند کلمات، همچون سنگ‌های بستر رودخانه برای رفتن به آن طرف 
رودخانه هستند... برای ما مهم رفتن به آن طرف رودخانه است!«

خوشحالم که نکته رو گرفتی!...

چای و گپ
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S O F T W A R Eیك نرم‌افزاریک ترفند
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در تصویر بالا به راحتی می توان دیدک ه چه طور توت فرنگی، قسمت پایینی قاشق و قسمتی از جدارهک اسه در ناحیه تمرک ز قرار دارند؛ در حالیک ه بقیه اجزاء خارج 
از این محدودهک می تار تر به نظر می آیند. به این حالت عمق میدان می گویند. 

پیاده سازی این حالت در فتوشاپ بسیار ساده است. دو فاکتور مهمک ه نقش عمده ای در پیاده سازی این روش در فتوشاپ دارند عبارتند ازشبیه سازی فاصله 
و احساس تمرکز. 

انجام یک سری تمرین و نمایش چند روش،  با  در این قسمت قصد داریم 
نحوه افزودن عمق به تصاویر گرافکیی و یا شبیه سازی آن را آموزش دهیم. 
به  می کند  عمل  موثر  بسیار  مجازی  تصاویر3بعدی  درساخت  تکنیک ها  این 
گونه ایک ه چشم انسان با تطبیق تصاویر و اشیاء و تمرکز بر روی یک یا چند 

شیء خاص، آن ها را برجسته تر و شفاف تر از دیگر اشیا خواهد دید.

عمق میدان چیست؟ 
به  و  می کنیم  مبحث خودداری  این  علمی  و  تعریف دقیق  از  این قسمت  در 
مات  جلوه های  ایجاد  عامل  میدان  عمق  می کنیمک ه  بسنده  نکته  همین  ذکر 
درعکاسی است. در واقع عمق میدان این امکان را می دهدک ه بر روی قسمتی 
از تصویر تمرک زک نید در حالیک ه قسمت دیگری از همان تصویر در محدوده ی 

توجه شما نباشد. 
برای درک ساده تر این موضوع به تصویر دقتک نید. 

بهبودتصاویرگرافیکی 
باتعیین عمق میدان
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مثال 1- عمق در میان اجسام
در این مثال به وسیله نحوه ی چینش ابرها و اندازه آن ها می توان به وجود فاصله در 

بین آن ها پی برد. 
اجسام دورترک وچک تر و در پشت اجسامی قرار دارندک ه به نظر نزدیک تر می آیند. 

ضمن اینکه تمرکز در این مثال بوسیله اندکی محو شدگی در ابرهاییک ه خیلی نزدیک 
یا خیلی دور هستند 

نشان داده شده است. همین امر سبب می شود ابرهاییک ه در میانه قرار دارند بیشتر 
در ناحیه تمرکز قرار داشته باشند.

مثال 2- عمق میدان در یک طرح
به مثال بالا دقتک نید. در عکس اول این طور به نظر می رسدک ه هر دو چرخ در یک 

فاصله از بیننده قرار دارند و چرخ سمت چپک می بزرگ تر از سمت راستی است. 
به منظور ایجاد عمق در تصویر بهتر است ابتدا جایگاه اشیاء را تنظیم نمایید. همان طور 
که در مثال پایین می بینید چرخ سمت راست به نظر عقب تر از چرخ سمت راست قرار 
دارد. نه فقط چرخ سمت راست عقب تر به نظر می آید، بلکه این طور تصور می شودک ه هر 
دو چرخ از لحاظ اندازه یکسان هستند و این تفاوت ناشی از دوری و نزدیکی آنهاست. 

برای ایجاد ناحیه تمرک ز،ک می محو شدگی به چرخ سمت راست اعمالک رده ایم. ضمن اینکه 
با اضافهک ردن یک لایه گرادینت به تصویر آن را از لحاظ نور دهی تنظیمک رده ایم.
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تصویر مقابل از 4 لایه تشیکل شده استک ه به ترتیب بزرگ،متوسط،ک وچک 
به  را  از اشیاء  ابزارMove هرک دام  به وسیله  نامیده می شوند.  و پس زمینه 
قسمتی در سندتان بکشید به طوریک ه شی بزرگتر در نزدیکترین فاصله به 

بیننده قرار داشته باشد.
نکته : ما برای درک بهتر این مفهوم از تعدادی خطوط راهنماک مک گرفته ایم.

تمرکز  باید  شیء  رویک دام  بر  بگیریدک ه  تصمیم  باید  قسمت  این  در  حال 
 بیشتری انجام شود. احتمالا متوجه خطوط افقی تیره در تصویر بالا شده اید. 
2 خط را انتخابک نید و تلاشک نید تمرکز را بر حد فاصل این دو خط قرار دهید 
)تصویر را تیزتر -sharp-ک نید( و بالطبع اشیاییک ه خارج از این محدوده قرار 
می گیرند راک می محوک نید. هر چه شی از این ناحیه دورتر باشد، محو شدگی 

بیشتری به آن اعمالک نید.
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در تصویر بالا ناحیه تمرکز با رنگ سبز مشخص شده است.

در تصویر بالا عمق میدان قابل مشاهده است.اینک ار به سادگی هر چه تمام تر و با 
کم ترین ابزار و در هرک جا قابل پیاده سازی می باشد!
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در این شماره 
قصد داریم تا نحوه ی ایجاد یک موج انفجار 

قدرتمند را آموزش دهیم. چیزی شبیه موج های انفجار در 
فیلم های هالیوودی از جمله ماتریکس. اگر چه با دیدن این تصاویر این 

طورالقا می شودک ه ممکن استک ار سختی در پیش داشته باشیم، اما آن قدر همک ه 
فکر می کنیدک ار مشکلی نیست. بیایید یک بار با هم امتحانک نیم. 

تصویر نهایی :
قبل از شروعک ار بهتر است نگاهی به تصویری بیاندازیمک ه انتظار می رود در پایانک ار ببینیم.

تمند
ر قدر

	 ایجاد یک موج انفجا
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مرحله 1: 
سایز  و  بازک نید  جدید  سند  یک 
قرار دهید.  روی 600*800  آنرا 
یک  تصویر  اینترنت  از  می توانید 
تصویری  انتخابک نید.  را  جاده 
زیر  در  انتخابک رده ایم  ما  که 
جدید  فایل  در  را  آن  می بینید. 

قرار دهید.
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مرحله 2: 
در این مرحله به تصویر یک شخص احتیاج داریم. 

تصویریک ه انتخابی ما در آدرس http://www.sxc.hu/photo/853035 قابل مشاهده است. وقتیک ه عکس مورد 
نظررا یافتید وقت آن رسیدهک ه تصویر شخص را از پس زمینه عکس جداک نید. بهترین راه استفاده از ابزار 

Pen) P( است. یک مسیر مانند شکل زیر ایجادک رده و سپس این مسیر را به حالت انتخاب تبدیلک نید.
 برای اینک ارک لید Ctrl + inter را فشار دهید. 

حال مسیر Layer>Layer Mask>Reveal Selection را دنبالک رده و در آخر لایه مورد نظر را نام گذاریک نید. ما 
نام آن را لایه مرد می گذاریم.

مرحله 3: 
به مسیر Edit>Transform>Scale رفته و اندازه تصویر مرد راک م 
کنید. سپس مسیر Edit>Transform>Flip Horizontal را دنبال 
کنید.اینک ار را برای هماهنگی با جهت تابش نور انجام می شود. 
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مرحله4: 
به مسیر Image>Adjustments>Curves رفته 
و تصویر مرد راک می تیره ترک نید تا بیشتر 
با تصویر پس زمینه هماهنگ شود. عکس 
زیر در میزان تیرگیک ار، شما را راهنمایی 

می کند. 

مرحله5: 
کلیک Ctrl را پایین نگه داشته و بر روی لایه ی مردک لیکک نید. با این 
کار یک حالت انتخاب مربعی به دور مرد رسم می شود. در این هنگام 
یک لایه جدید ایجادک رده و نام آن را سایه بگذارید و سپس آنرا با 
Edit>Transform>Distort را دنبالک رده و با  رنگ سیاه پرک نید. مسیر 
حرکت دادن رئوس سایه تلاشک نید به سایه حالت پرسپکتیو دهید. 
محو  را  سایه  وک می  رفته   Filter>Blur>Gaussian Blurمسیر به  آخر  در 

کنید. 

مرحله6: 
ابزار Ellipse)U( را بردارید و در نوار 
منو در بالای صفحه گزینه Paths را 
انتخابک نید. یک دایره مانند شکل 
A ابزار  سپس  و  رسمک رده   زیر 
)Direct Selection Tool( را برداشته و 
قسمت پایین دایره را مانند شکل 

زیر تنظیمک نید. 
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مرحله7: 
یک لایه جدید ایجادک رده و آنرا لایه ابر نامگذاریک نید. سپس به مسیر Filter>Render>Clouds رفته و آن 
را با نگه داشتنک لید Alt اعمالک نید. سپس به پالت Path's  رفته و مسیر را تبدیل به حالت انتخاب 

کرده و سپس لایه را ماسکک نید. 

نکته: 
استفاده می کنید، ممکن است نیاز باشد چندین بار این فیلتر را   Render>Clouds هنگامیک ه از فیلتر
اعمالک نید تا به نتیجه مورد نظرتان دست پیداک نید. توصیه می کنیم تا زمانیک ه قسمت های تیره 

روشن تصویر در بهترین حالت ممکن قرار گیرند این عمل را تکرارک نید. 

مرحله8: 
این  به  مربوط  صفحه  در  و  رفته   Filter>Liquify مسیر  به 
انتخابک نید. سپس در قسمت  را   )Bloat) B ابزار  فیلتر، 

تنظیمات مقادیر زیر را قرار دهید.
550 :Brush Size

100 :Brush Density
100 :Brush Pressure

 60 :Brush Rate
 75 :Turbulent Jitter

Show Backdrop را به حالت انتخاب در  پس از آن قسمت 
بیاورید. اینک ار به شما امکان می دهد تا ابر ها و پس زمینه 
برای فهمیدن مکان دقیق استفاده  ببینیدک ه  را همزمان 
انجامک ار  از  بعد  بود.  خواهد  موثر  بسیار   Bloat ازابزار 
دوباره Show Backdrop را از حالت انتخاب خارجک رده و به 
این ترتیب می توانید به راحتی از ابزار مورد نظر استفاده 

صحیح نمایید.
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مرحله9: 
به را  ابر  لایه  به  مربوط   Blend Mode 
Soft Light تغییر دهید. سپس یک لایه جدید 
دیگر ایجادک رده و نام آن را ابر2 گذاشته و 
مراحل 7 و 8 را مجددا تکرار نمایید. ما به 
یک لایه دیگراحتیاج داریم تا به موج ایجاد 
 Blend شده حالت طبیعی تری بدهیم.این بار

Mode را در حالت Multiply قرار دهید. 
مجددا یک لایه دیگر ایجادک رده و نام آنرا ابر3 
گذاشته و مراحل 7و8 را برای آن تکرارک نید. 
برای این لایه در قسمت Blend Mode حالت 

Color Dodge را انتخابک نید. 
از استفاده  قسمت  این  در  گام   آخرین 
)E (Eraser Tooاستک ه به وسیله آن بعضی از 
قسمت ها را پاک می کنیم. این لایه برای ایجاد 

روشنی درتوده ابرها استفاده می شود. 

مرحله10: 
هر 3 لایه ابر را به صورت یک گروه در آورده و سپس 
Layer>Layer Mask>Reveal All را دنبالک نید.  مسیر 
سپس ابزار Brush)B( را انتخابک رده و رنگ سیاه را 
برای آن در نظر بگیرید و قسمتهایی از توده ابر راک ه 

به زمین نزدیکتر است به حالت ماسک در آورید.

مرحله11: 
مسیر   به  و  انتخابک رده  را  ابر  لایه 

Filter>Sharpen>Sharpen More بروید. 
سپس همین فیلتر را برای لایه های ابر2 و 

ابر 3 نیز تکرارک نید. 
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مرحله12: 
یک لایه جدید ایجادک رده و نام آن را تابش بگذارید. آن 
را با رنگ سفید پرک نید. به پالت Path بروید و مطابق 
مرحله نهم، یک حالت انتخاب ازمسیر توده ابربسازید. 

سپس لایه را ماسکک نید. 
پس ازآن به مسیر Layer>Layer Style>Outer Glow رفته 

و تنظیمات پیش فرض رااعمالک نید. 
سپس به مسیر Layer>Layer Style>Create Layer بروید. 
این دستور یک لایه جدید از لایه تابش  می سازد. پس 

از آن می توان لایه سفید را حذفک رد. 

مرحله14: 
با  ایجادک نید.  ابر  لایه های  زیر  در  جدید  لایه  یک 
استفاد از ابزار Elliptical Marquee یک ناحیه انتخاب 
مانند شکل زیر ایجادک نید. لایه را با رنگ مشکی و 

درجه روشنی ) Opacity( 40درصد پرک نید. 

مرحله13: 
یک پوشه با نام نورایجادک نید. لایه تابش را به این پوشه منتقلک نید. سپس لایه تابش را فعالک رده و 
مسیر Layer>Layer Mask>Reveal All را دنبالک نید. ابزار Brushرا انتخابک رده و رنگ سیاه را به آن اختصاص 
دهید. پس از آن لایه تابش را ماسکک نید. ما فقط به خطوط محیطی احتیاج داریم با این حال باقی گذاشتن 

بعضی از نقاط روشن در وسط تصویر، در ایجاد جلوه زیبا بسیار موثر است. 
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مرحله15: 
رفته   Layer>Layer Mask>Reveal All مسیر  به 
وسپس ابزار Gradient)G( را انتخابک نید 
و از یک گرادینت سیاه و سفید به عنوان 
شکل  مانند  سپس  استفادهک نید.  مثال 

زیرلایه را ماسکک نید. 

مرحله16: 
مسیر  به  و  ایجادک رده  لایه  از  یکک پی 
سپس  بروید.   Layer>Layer Mask>Apply
انتخاب  را   Edit>Transform>Distort مسیر 
کنید. سپس تمامک ارهاییک ه ما برای ایجاد 
سایه مرد انجام دادیم برای این لایه تکرار 
کنید. این 2 لایه را باهم گروهک رده و نام آن 

را به سایه تغییر دهید. 

مرحله17: 
ایجادک نید.  جاده  تصویر  بالای  در  دقیقا  جدید  لایه  یک 
مسیر  سپس  و  رفته   Filter>Render>Clouds مسیر  به 

Filter>Distort>ZigZag را دنبالک نید.
مقادیر Amount  Ridges=100=5 را در نظر بگیرید. برای قسمت 

Style، گزینه Pond Ripples را انتخابک نید. 
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مرحله18: 
حال به مسیر Edit>Transform>Distort رفته 
و آنقدر لایه را تغییردهید تا به بهترین 
حالت پرسپکتیو دست پیداک نید. پس از 
آن Blend Mode لایه را به Overlay تغییر 
دهید. مجددا فیلتر Render Clouds را اعمال 
کنید. ممکن است تیجهک ارک می تغییرک ند. 
در این حالت ممکن است احتیاج شود تا با 
پاکک ردن بعضی قسمت ها به تصویر حالت 

واقعی تری بدهیم. 

مرحله19: 
 یک ناحیه انتخاب به شکل بیضی درست مانند شکل زیر 
یک  پرک نید. سپس  رنگ مشکی  با  را  آن  و  ایجادک رده 
ناحیه انتخاب بیضی شکل دیگر - اماک وچکتر - ایجادک رده 
 )Magic Wand)W و آن قسمت از لایه را پاکک نید. با ابزار

قسمت سیاه لایه را انتخابک نید.

مرحله20: 
یکک پی از لایه جاده تهیهک رده و آنرا انتخابک نید. مطمئن 
دسترس  در  مرحله 19  انتخابی  ناحیه  هنوز  شویدک ه 

شماست. 
 Layer>Layer Mask>Reveal Selection مسیر  به 
را   19 مرحله  از  شده  ساخته  بیضی  می توان  بروید. 

پاکک رده و یا آن را پنهان نمود. 
به مسیر Layer>Layer Styles>Bevel and Emboss بروید. 
ایجاد موج می باشد.  این مسیر یک روش دیگر برای 

شما به راحتی می توانید با Displaceک ارک نید. 

BOOM T U T O R I A L S44

www.IrPDF.com

www.IrPDF.com www.IrPDF.comwww.IrPDF.com



مرحله21: 
به مسیر Layer>New Layer Fill>Gradient رفته و 
از حالت Radial در این قسسمت استفادهک نید. 
و   ddc456# ازک دهای  می توانید  رنگ ها  برای 
بر روی  را  استفادهک رده و Mode لایه   2f1e00#

Color Dodge بگذارید. 

مرحله22: 
نیز  دیگر  عکس  یک  از  ما  مرحله  این  در 
این  است  فقطک افی  استفادهک رده ایم. 
عکس را در بالای تمام لایه ها قرار داده و 

Mode لایه را بر روی Overlay بگذارید. 

مرحله23: 
حالا بهتر استک می روی تنظیمات عکسک ارک نیم. 

ابتدا تصویر مرد راک می تاریک ترک نید. 
ابزار)Burn(s را انتخابک رده و پشت مرد راک می 
 Soft Light لایه را روی Mode تیرهک نید. پس از آن
قرار داده و در صورت نیاز بعضی از قسمت های 

ابر را حذفک نید. 
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مرحله24: 
مرد  لایه  درزیر  جدید  پوشه  یک 
قدرت  را  آن  نام  و  ایجادک رده 
بگذارید و Mode لایه را بر روی 
پس  دهید.  قرار   Color Dodge
از آن یک لایه جدید در داخل این 
ابزار  از  ایجادک نید.سپس  پوشه 
استفاده  سفید  رنگ  با   Brush
کرده و نورهاییک ه از دست مرد 

بیرون می آید را ایجادک نید. 

با درجه سختی 0 درصد استفاده  نکته: از یک براش ساده 
کنید. یک لایه جدید ایجادک رده واز یک سری قلم مو برای 

ایجاد جلوه های بهتر استفادهک نید.
سایت از  استفادهک ردیم  اینجا  در  ما  موهاییک ه   قلم 
http://www.brusheezy.com/brush/442-Rise-Brushes انتخاب شده اند. 
را   Outer Glow Layer Style گزینه  از قسمت  از آن،  پس 

فعالک نید.

مرحله25: 
تصویرک امیون را به داخل سندتان واردک نید. سپس با استفاده از ابزار Magic Wand (W( تصویر پس 
زمینه را حذفک نید. پس از آن به مسیر Edit>Transform>Flip Horizontal رفته وک امیون را بهک نار 

جاده انتقال دهید.
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مرحله26: 
از  لازم  میزان  به  تیرهک ردنک امیون  برای 
 Image>Adjustments>Curves مسیر 
tRec  استفادهک نید. پس ازآن با استفاده از 
angular Marquee)M( یک ناحیه انتخاب به 

اندازهک می بزرگتر ازک امیون رسمک نید. 
 به مسیر Filter>Blur>Radial Blur رفته و تنظیمات
Amount=2Method=Spin،quality=Best را اعمال 

کنید. 
با  را   Filter>Blur>Motion Blur فیلتر  سپس 
اعمال    Distance= 3 و   =  angle  -75 تنظیمات 

کنید.

مرحله27: 
برایک امیون  ای  سایه  باید  حال 
پس  اینک ار  برای  ایجادک نیم. 
روی  لایهک امیون،  انتخاب  از 
گزینه و  راستک رده   آنک لیک 
انتخابک نید.  را   Select Pixels
سپس یک لایه جدید ایجادک رده 
و آنرا با رنگ مشکی پرک نید و در 
زیر لایهک امیون قرار دهید. سپس 
 Edit>Transform>Distort مسیر  به 
برای  را  لازم  تنظیمات  و  رفته 
دادن  نشان  واقعی تر  چه  هر 
فیلتر دهید.سپس  انجام   سایه 
 F i l t e r > B l u r > G a u s s i a n B l u r 
روشنی  درجه  و  اعمالک رده  را 
60درصد  روی  را  لایه   )Opacity(

قرار دهید. 
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مرحله28: 
هم  با  را  سایه  و  لایه هایک امیون 
آنراک امیون  نام  و  گروهک رده  یک 
بگذارید. سپس پوشه های خود را 

سازماندهیک نید. 

پایانک ار : 
شما می توانید المان های دیگری نیز به تصویر خود اضافهک نید مانند ایجاد ترافیک در صحنه و یا چند 
)curves)Ctrl+M ماشین دیگر، اما یادتان باشد برای هماهنگی بیشتر بین این المان ها و تصویر اصلی از
استفادهک نید تا تصویر واقعی تر به نظر بیاید. برای اعمال افکت هاییک ه در این آموزش بهک ار گرفته 
شد روش های متعددی وجود داردک ه نتایج اکثر آنها شبیه به یکدیگر است. بنا براین روشیک ه احساس 

می کنید بهترین نتیجه را به شما می دهد انتخابک نید.
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ایجاد حرکت پرچم در باد توسط نرم افزار مایا 
پیش گفتار : آن چه لازم است در ابتدای آموزش به آن پرداخته شود این استک ه پیاده سازی یک ذهنیت در مایا، مانند تمام نرم افزار های دیگر به طرق 
مختلف قابل انجام است. بنابراین ممکن است راههای بهتری هم برای ایجاد این جلوه وجود داشته باشد. هدف ما صرفا آشنایی شما دوستان عزیز با نحوه ی 

پیاده سازی یکی از این روش ها ست. 
1-به منوی Create رفته و از زیر منوی باز شده گزینه Polygon در ابتدا بهتر است نگاهی به نتیجهک ار بیندازیم. 

را زده و در ادامه plane را انتخابک نید.

Plane -2 ایجاد شده را در محور 
z به مقدار 90 درجه بچرخانید. 
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 ncloth را مجددا انتخابک رده وسپس از مجموعه پنل ها  مجموعه plane -4
 Ncloth> Create را انتخابک رده  و از منو های جدید ظاهر شده به مسیر

Ncloth بروید.

 Freeze و  clear history را با فشار دکمه های plane  3- تنظیمات احتمالی
transformation به حالت اول برگردانید.

5- از منو Field فیلد Gravity را برروی plane خود اعمالک نید )حتما 
قبل از انتخاب این فیلد plane خود را انتخابک رده تا تنظیمات مورد 

نظردقیقا روی plane اعمال شود(.

و  راستک لیکک رده  بررویک ار   -6
گزینه Vertex را انتخابک نید. 
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تصویر  مانند  نقاط  انتخاب  از  بعد   -8
گزینه  و  رفته     nConstraint منوی  به 

Transform  را انتخابک نید. 

نمایی از نتیجهک ار : 

Point -7های اولین ردیف سمت چپک ار را Selectک نید. 

9-ک افی است است برای اتمامک ار به مشخصات Gravity بروید و مشخصات 
را مانند تصویر تغییر دهید )البته این مشخصات بسته به سلیقه و هدف شما 

میتواند متفاوت باشد(.
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VEGAS تکنیک هایی از کار با افکت
After Effects Photoshop

نمونه نهاییک ار:

 Photoshop 1. برای شروع در ایجاد این نوع انیمیشن، ما در ابتدا نیاز به برنامه
یا Illustrator داریمک ه بتوانیم توسط این نوع برنامه ها شکل زیر را ایجاد 

کنیم:

نکته:این شکل را می‌توان توسط ابزار mask خود نرم‌افزار After Effects نیز 
ایجادک رد.
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2. بعد از رسم شکل، آن را با فرمت jpg ذخیرهک رده و سپس به سراغ نرم 
افزار After Effects بروید و یک Composition جدید با اندازه‌های گفته 

شده در تصویر ایجادک نید:

گزینه  و  راستک لیکک نید  پنل  درون  و  رفته   project پنل  به   .3
import---File… را برای واردک ردن تصویر انتخابک نید.

4. از داخل پنل project فایل تصویر 
را به داخل Time line بکشید: 
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و  رفته   Effects پنل  به   .6
)روبرویک لمه   Textbox در 
را   Vegas ک  لمه  ،)Contains
افکت  فایل  پیداک ردن  برای 
وگاس تایپک نید. سپس با دوبار 
کلیکک ردن برروی افکت وگاس 
یا درگک ردن وک شیدن آن روی 
لایه جدید ایجاد شده، افکت را 

اجراک نید:

5. یک Solid ایجادک نید و مشخصات آن را مانند شکل تنظیم نمایید:

شماره هاي قبلي نشريه شات رو داري؟ 
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9. با زدن دکمه و عدد صفر برروی صفحهک لیدک ار خود را تستک نید. سپس مجددا به پنل 
Effects رفته و این‌بارک لمه Glow را تایپ نمایید 
و در ادامه این افکت را برروی لایه جاری اعمال 

کنید: 

یافته را در شکل برای  Vegas را مانند شکل تنظیمک نید )موارد تغیییر  7. مشخصات افکت 
راحتی شما دوستان علامت گذاریک رده ایم(

8. همانطورک ه در تصویر مشاهدهک ردید Keyframe مربوط به گزینه Rotation را فعالک ردیم 
)برای دادن حالت انیمیشن ویا همان رفت و برگشت(. پس برای  اتمام این قسمت با زدنک لید 

End به انتهای Timeline رفته و درجه 
زیر  مانند شکل  را   Rotation مرتبه  و 

تنظیمک نید:
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مشخصات این افکت را مانند شکل زیر تنظیمک نید  	.10
  897ED8#:B058083 رنگ# :A رنگ

نتیجهک ار  به  اگر  مشکل: 
 Glow افکت  اعمال  از  بعد 
نگاهک نید متوجه میشود این 
افکت موجب شده مقداری از 
قسمت هاییک ه نباید درک ار 
محیطک ار  وارد  بشوند  دیده 
مشکل  رفع  برای  اند  شده 
مانند  میتوانید  شکل  مانند 

شکل عملک نید.

تصویری از مشکل ایجاد شده:

راه حل رفع مشکل ایجاد شده 
Solid به بزرگ ترک ردن
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11. در ادامه برای دادن حالت مانیتور به طرح باید از 
افکت Grid استفادهک نیم. پس ابتدا یک Solid ایجاد 
کرده و  مجددا« به پنل افکت رفته وک لمه Grid را 
برای پیداک ردن افکت Grid تایپک نید و در ادامه 

این افکت را برروی لایه جدید اعمالک نید:

12. رنگ خطوط را به مشکی تغییر داده و نقاط 
Anchor و Corner را با ماوس به محل های 

گفته شده درک ادر منتقلک نید:

13. در ادامه برای اتمامک ار  Mode لایه‌ی جدید 
ایجاد شده را به HARD LIGHT تغییر دهید:

14. نمایی از طرح و انیمیشن نهایی:
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طراحی ابتکاری:
صفحات شروع چشمگیر

بخش نخست
معمولا طراحانک سری از ثانیه فرصت دارند تا چشمان بینندگان را به اثر خود جذب نمایند.بیان صریح مفهوم، استفاده به جا از تایپو گرافی و بهک ار گیری مناسب 

عکس تاثیر بسیار مهمی  بر بینندگان- حتی در همین زمانک وتاه - خواهد گذاشت.
بنابراین ساده ترین راه برای بدست آوردن بهترین نتیجه و ماندگارترین اثرممکن، استفاده از یکسری قوانین اساسی  طراحی می باشد. هر چقدر اقدامات سنتی 
وک لاسیک ممکن است خستهک ننده باشد، در مقابل راه های ابتکاری می تواند بر جذابیت اثر، تاثیر مثبت بگذارد. معمولا طراحان برای جذب بیشتر بینندگان 
دست به اقدامات خلاقانه ای می زنند.  علی رغم تمام این مطالب، برای دستیابی به راه های ابتکاری و فاصله گرفتن از روش های معمول و سنتی فرصت بسیاری 

برای تجربه های جدید است. ما با عبور از این مسیر تجارب زیادی  را با خود همراهک رده ایم. در نتیجه شما نیازی به طی این مسیر نخواهید داشت‌!
از آنجاک ه در تبلیغات، صفحات شروع اهمیت به سزایی دارند، جالب است بدانیدک دام روش طراحان ، بدعت و نو آوری در طراحی صفحات اول را ارئه خواهد داد. 

بیایید با هم نگاهی به چند اثر غیر متعارف و در عین حال برجسته و قابل توجه بیاندازیم .

1- پویا، محاوره ای و شیک 
یا  نماید.  استفاده  رنگی  مداد  از  استک ه  داده  ترجیح   Leo Burnet ظاهرا 
حداقل اینک ار را در طراحی اولیه سایت خود بهک ار برده است. در طراحی 
سایت LeoBurnett.caک ه با فلش انجام شده است از یک مداد به جای اشاره 
گر موس استفاده شده استک هک اربران می توانند آنرا در 3 بعد به حرکت 

در آورند. یک اثر فوق العاده زیبا، جذاب وک اربر پسند.
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 WWW.Capitalcomm..com.my به نظر می رسد لینک های مربوط به سایت
به نخی آویزان شده اند. برای وارد شده به صفحات داخلیک ابران باید این 
لینکها را به پایین بکشند. یک طراحی فوق العاده زیبا و یک روش ابتکاری 

برای نمایش صفحات.

سایت  فلش  درطراحی 
از   www.yammat.com
شده  استفاده  لینکهایی 
از  عددک ش  دو  با  که 
شده اند. محدود  طرفین 
لینک  یک  فشار  محض  به 
در  حرکت  به  صفحه  تمام 
می آید! عکس پس زمینه 
بارگذاری مجدد  با هر  نیز 

تغییر می کند.

www.sectionseven.com  نمایش  منوهای عمودی محاوره ای. سایت 
و  است.  طراحیک رده  به صورت صفحاتک تاب  را  داخلی اش  صفحات 

حس خواندنک تاب را به بیننده القا می کند.
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تنهاک اربران نیستندک ه می توانند با سایت ها بازیک نند. سایت ها نیز می توانند 
اختیار  در  با   www.Flaboy.com سایت  منوهای  بازیک نند!  خود  باک اربران 
گرفتنک نترل موسک اربر را به صفحه ای از پیش تععین شده هدایت می کند. 

یک طراحی زیبا و پیاده سازی جذاب تر ! 

این   www.mhq.nl سایت  باشد.  شکوه  با  بسیار  می تواند  سایت  یک  منو های 
امرراثابت مي كند. 

2- مرور یک سایت به روش جدید
به نظر شما چه طور می توان یک سایت را مرورک رد بدون اینک ه بر روی لینکی 

کلیکک نیم؟ یک روش ابتکاری و یک تجربه ی طراحی موفق!
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3- استفاده از طراحی بهینه واسطک اربری
با   http://www.pr0jects.com/portfolio سایت  در   Jason Hickner
استفاده از منوهایک شویی و بهک ارگیری تایپو گرافی خیرهک ننده 

وک ادر های محاوره ای پویا صفحاتی زيبا خلقک رده است. 

سایت http://lab.mathieu-badimon.com  نیزبه همان روش 
طراحی شده است . 

http://www.lancewyman.com  ویترینی ازک ارهایش را به شکل 
مارپیچ در آورده و آخرینک ارهایش را در بیرونی ترین حلقه 
قرار داده است . اینک ار باعث نمایشک ارهای بیشتر- در آن 
طراحی  فلش  با  نیز  این سایت  میشود.   بهک اربران  واحد-  

شده است. 
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4 - ارائه ی نمایی متفاوت

  http://www.davorvaneijk.com سایت  در 
یک طراحی غیر معمول  بهک ار گرفته شده است. 
منوهای  به  تند  زاویه  یک  با  توانند  می  کاربران 

طراحی شده با آیکون نگاهک نند. 
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6 - استفاده از قدرت عناصربصری 
http://www.73dpi.net پیامش را به وسیله تصاویر القا مکیند نه باک لمات. 
و  توضیح  هیچ  بدون  است؛  آمده  در  نمایش  به  دیگری  از  بعد  یکی  کارها 

تفصیلی. 
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5 -استفاده از ارتباطات بصری 
http://www.laptop.  - تاپ«  لپ  اولک مپین »هرک ودک یک  صفحه 
org – یک صفحه پر سرو صدا نیست. هر عکس شما را به قسمت های 
مختلفی از سایت هدایت میک ند. به عبارتی هر آیکون نقش یک منو را 

ایفا میک ند. یک طراحی نا‌متعارف اما با مفهوم .
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http://www.sohail2d.com/component/banners/click/26 
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